Wednesday, June 15, 2011

AIX Command for SAP Basis

Simple commands
chgrp grp filelist : Change the group that the file(s) belong to.
chmod 777 filelist : Change the rights of the file(s). 777: owner-world-user. 7: read-write-delete (=111)
chown user filelist : Change the owner of the file(s)
cp file1 file2 : Copy file1 to file2
cp /dev/null file : Clear all contents of file
errpt : Hardware error-report (IBM-unix)
ls –ltr : Show filelist, –parameters: l: show fileattributes , t: sort by time, r: reverse sortorder
more

mv file1 file2 : Move command
ps –ef : Show all running processes, -e, -f
vi : The famous vi-editor

2 A little more complex commands
kill : Kill a process as if it is cancelled. Child processes are killed as well.
kill –1 : Kill a process as if the user is logging out. Child processes are killed as well.
kill –9 : Kill a process as brutal as possible. Child-processes are not touched.
kill –USR2 : Increases TRACE by 1
kill –USR1 : ecreases TRACE by 1. When TRACE = 0 all open trace files are closed and can be cleared using ‘cp /dev/null filename’.
lslv : Show the logical volumes
lsvg : Show the volumegroups
sappfpar check pf= : Checks the profileparameter. Do they exist and do they have correct values.
set VAR VAL : set environment variable VAR to value VAL
printenv : prints the environementvariables
ps –ef grep xxx : Monitor processes with name containing xxx
ps –u : Monitor processes run by user

No comments: